Verification is currently underway for the maintenance items.
Posted Oct 01, 2024 - 23:18 AEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 01, 2024 - 22:15 AEST
Update
TurnPoint Assist will be undergoing required maintenance to support future upgrades of the software. You will be able to access the system but in a read only mode.